diff --git a/recipes-kernel/linux/linux-yocto-custom/linux-yocto-custom.bb b/recipes-kernel/linux/linux-raspberrypi-custom/linux-yocto-custom.bb
similarity index 100%
rename from recipes-kernel/linux/linux-yocto-custom/linux-yocto-custom.bb
rename to recipes-kernel/linux/linux-raspberrypi-custom/linux-yocto-custom.bb
diff --git a/recipes-kernel/linux/linux-yocto-custom/myconfig.cfg b/recipes-kernel/linux/linux-raspberrypi-custom/myconfig.cfg
similarity index 90%
rename from recipes-kernel/linux/linux-yocto-custom/myconfig.cfg
rename to recipes-kernel/linux/linux-raspberrypi-custom/myconfig.cfg
index 9823474535368446f518b3a61bf798f061577138..d2d3b838208e20b926a75ce9578a25225527ff43 100644
--- a/recipes-kernel/linux/linux-yocto-custom/myconfig.cfg
+++ b/recipes-kernel/linux/linux-raspberrypi-custom/myconfig.cfg
@@ -1,10 +1,20 @@
+# Disable IPv6
+
 CONFIG_IPV6=n
 
+# Enable USB gadget
+
 CONFIG_USB_SERIAL_CONSOLE=y
 CONFIG_USB_SERIAL_GENERIC=y
 CONFIG_USB_G_SERIAL=y
 CONFIG_USB_SERIAL=y
 
+# Enable GPIO sys fs
+
+CONFIG_EXPERT=y
+CONFIG_GPIO_SYSFS=y
+CONFIG_GPIO_AGGREGATOR=y
+CONFIG_GPIO_VIRTIO=y
 
 # Disable bluetooth, copied from diff of menuconfig
 
diff --git a/recipes-kernel/linux/linux-raspberrypi_%.bbappend b/recipes-kernel/linux/linux-raspberrypi_%.bbappend
new file mode 100644
index 0000000000000000000000000000000000000000..7c4f1b33deb007175c2c1caaee586875632ddcaf
--- /dev/null
+++ b/recipes-kernel/linux/linux-raspberrypi_%.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/linux-raspberrypi-custom:"
+SRC_URI:append = " file://myconfig.cfg"
+
diff --git a/recipes-kernel/linux/linux-yocto_%.bbappend b/recipes-kernel/linux/linux-yocto_%.bbappend
deleted file mode 100644
index 271fe8f3570ace7f9db8a31ed795d98461d2b9c2..0000000000000000000000000000000000000000
--- a/recipes-kernel/linux/linux-yocto_%.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/linux-yocto-custom:"
-SRC_URI:append = " file://myconfig.cfg"
-